Route Redistribution Between OSPF and RIP

Route redistribution is a method to redistribute routes learned by a routing method to another routing method. In this post, we will explain how to perform route redistribution between OSPF and RIP routing protocols. If you are interested, you can visit the following posts to know more about route redistribution.

  1. Understanding the route redistribution process
  2. Route redistribution between OSPF and EIGRP
  3. Route redistribution between RIP and EIGRP

To demonstrate how to perform redistribution between OSPF and RIP, let’s have a close look up at the following topology. If you are using a simulator such as Cisco Packet Tracer or GNS3, create the following topology and configure the appropriate IP addresses.

Route Redistribution between OSPF and RIP

Perform Route Redistribution Between OSPF and RIP

  1. After configuring the appropriate IP addresses on the devices, the next step is to configure routing. As per the above-mentioned topology, we have to configure RIP routing on Router1 and Router2. To do so, execute the following commands.
    Router1(config)#router rip
    Router1(config-router)#network 10.0.0.0
    Router1(config-router)#network 192.168.0.0
    Router1(config-router)#exit
  2. After configuring RIP on Router1, switch to Router2’s console and execute the following commands to configure RIP routing.
    Router2(config)#router rip
    Router2(config-router)#network 192.168.0.0
    Router2(config-router)#exit
  3. On Router2, one interface is also connected to the OSPF area 0 network. So, use the following commands to apply OSPF routing on Router2. (100 is the AS number)
    Router2(config)#router ospf 100
    Router2(config-router)#network 192.168.1.0 0.0.0.255 area 0
    Router2(config-router)#exit
  4. The following figure shows the RIP and OSPF routing configuration of Router2.Configure RIP routing
  5. Once the Router1 and Router2 are configured, now it is time to configure Router3. To do so, use the following commands to configure OSPF routing.
    Router3(config)#router ospf 100
    Router3(config-router)#network 192.168.1.0 0.0.0.255 area 0
    Router3(config-router)#network 20.0.0.0 0.255.255.255 area 0
    Router3(config-router)#exit
  6. Next, move on to Router1 and execute the following command to show the routing table.
    Router1#show ip route

show ip route command

In the preceding figure, you can see that Router1 has only the network routes of RIP routing protocol. It cannot learn OSPF routes until we perform the route redistribution.

Redistribute RIP into OSPF

  1. In order to redistribute RIP routes into OSPF, the following commands should be executed on Router2.
    Router2(config)#router rip
    Router2(config-router)#redistribute ospf 100 metric 1
  2. The following figure shows how to redistribute RIP routes into OSPF.

Route redistribution between RIP and OSPF

Note: We recommend to have a close look up at the preceding figure to understand the syntax used to inject RIP routes into OSPF.

Redistribute OSPF into RIP

  1. In order to redistribute OSPF routes into RIP, the following commands should be executed on Router2.
    Router2(config)#router ospf 100
    Router2(config-router)#redistribute rip metric 1
  2. The following figure shows how to redistribute OSPF routes into RIP.

Redistribute OSPF routes into RIP

Note: Take a close look up at the preceding figure to understand the syntax used to inject OSPF routes into RIP. One of the most important factors that you should consider is OSPF Cost Metric.

Verifying Route Redistribution Between OSPF and RIP

  • Once you have redistributed RIP into OSPF and vice-versa, now, it is time to verify your configuration. To do so, execute the show IP route command and examine the routing table on a router.
    Router1#show ip route

Verify route redistribution between OSPF and RIP

  • Have you noticed any changes? Yes. In the preceding figure, you can see that 20.0.0.0/8 and 192.168.1.0/24 networks are added through the RIP routing method.
  • Next, verify the routing table on Router3.
    Router3#show ip route

Router Redistribution using Cisco Packet Tracer

  • In the preceding figure, you can see that 10.0.0.0/8 and 192.168.0.0/24 networks are added through the external OSPF protocol.
  • To further verify your configuration, you can test connectivity between Router1 and Router3 using the ping utility.

That’s all you need to perform route redistribution between OSPF nd RIP routing protocols. Was it helpful for you? Drop your feedback in the comment box. Would you like to share the article? please do share.

Posted in CCNA, Cisco Tagged with: , ,

Leave a Reply

Your email address will not be published. Required fields are marked *

*