How to Configure IS-IS in GNS3

In the previous posts, we explained the IS-IS routing protocol in detail. We recommend you to read those posts if you missed. In this post, we will learn how to configure IS-IS on Cisco router using GNS3.

To configure IS-IS routing protocol, we will use the following network topology. In the following network topology, R1 and R2 are connected through the Fa0/0 interfaces, while R2 and R3 are connected through the Fa0/1 interfaces.

Configure IS-IS on Cisco Router

Steps to Configure IS-IS

Let’s begin how to configure IS-IS on Cisco router. To configure IS-IS, you need to perform the following steps:

  1. On R1, execute the following commands to assign 1.1.1.1/24 IP address to the Loopback0 interface.
R1(config)#interface Loopback0
R1(config-if)#ip add 1.1.1.1 255.255.255.0
  1. Next, execute the following commands to assign 10.10.10.1/24 IP address to the FastEthernet0/0 interface and enable IS-IS for IP on the FastEthernet0/0 interface.
R1(config)#interface fa0/0
R1(config-if)#ip address 10.10.10.1 255.255.255.0
R1(config-if)#ip router isis
R1(config-if)#exit
  1. Next, execute the following commands to enable the IS-IS process and assign an area and a system ID. In this example, we will use 49.0001.1111.1111.1111.00 as a system ID.
R1(config)#router isis
R1(config-router)#net 49.0001.1111.1111.1111.00
  1. The following figure displays the IS-IS configuration of R1.IS-IS Configuration on Cisco Router
  1. Once you have configured R1, next, move on to R2, and execute the following commands to assign 2.2.2.2/24 IP address to the Loopback0 interface.
R2(config)#interface loopback0
R2(config-if)#ip add 2.2.2.2 255.255.255.0
  1. Next, execute the following commands to assign the IP address to the FastEthernet0/0 interface and enable IS-IS for IP to the FastEthernet0/0 interface.
R2(config)#interface fa0/0
R2(config-if)#ip address 10.10.10.2 255.255.255.0
R2(config-if)#ip router isis
R2(config-if)#exit
  1. Next, execute the following commands to assign 20.20.20.1/24 IP address to the FastEthernet0/1 interface and enable IS-IS for IP to the FastEthernet0/1 interface.
R2(config)#interface fa0/1
R2(config-if)#ip address 20.20.20.1 255.255.255.0
R2(config-if)#ip router isis
R2(config-if)#exit
  1. Next, execute the following commands to enable the IS-IS process, assign an area and a system ID. In this example, we will use 49.0002.2222.2222.2222.00 as a system ID.
R2(config)#router isis
R2(config-router)#net 49.0002.2222.2222.2222.00
  1. Next, move on to R3 and execute the following commands to assign 3.3.3.3/24 IP address to the Loopback0 interface.
R3(config)#interface Loopback0
R3(config-if)#ip add 3.3.3.3 255.255.255.0
  1. Next, execute the following commands to assign 20.20.20.2/24 IP address to the FastEthernet0/1 interface and enable IS-IS for IP to the FastEthernet0/1 interface.
R3(config)#interface fa0/1
R3(config-if)#ip address 20.20.20.2 255.255.255.0
R3(config-if)#ip router isis
R3(config-if)#exit
  1. Next, execute the following commands to enable the IS-IS process, assign an area and a system ID. In this example, we will use 49.0003.3333.3333.333300 as a system ID.
R3(config)#router isis
R3(config-router)#net 49.0003.3333.3333.3333.00

Verify IS-IS Configuration

Once you have configured IS-IS on all the routers, now verify your configuration. To verify the IS-IS routing configuration, execute the show ip route command and verify the routing table. You should be able to see the routes added by the IS-IS routing protocol. In addition, you can also test the network connectivity between R3 and R1 by executing the ping 1.1.1.1 command on R3.

In the following figure, you can see the routing information added by the IS-IS routing protocol.Verify IS-IS routing configuration

One more important command you need to consider is show clns neighbors. It displays the IS-IS neighbor routers. In the following figure, you can see that R2 has two neighbors R1 and R3. R1 is connected to R2 via the Fa0/0 interface and R3 is connected to R2 via the Fa0/1 interface.show clns neighbors

In this post, you have learned how to configure IS-IS on Cisco routers using GNS3. We would love to hear your suggestions. In the upcoming posts, we will configure IS-IS using a complex network topology.

Posted in Cisco, GNS3 Tutorials, Routing Tagged with: ,
3 comments on “How to Configure IS-IS in GNS3
  1. rags says:

    Superb systamatic and ultimate notes and clear cut explanation thanks a lot!!!!

  2. fUNK` says:

    if you want after IS-IS setup ping l0 you should add ip router isis on l0 int as well! very nice article!

Leave a Reply

Your email address will not be published. Required fields are marked *

*