EIGRP Configuration| Step By Step Guide

Before you can configure EIGRP (Enhanced Interior Gateway Routing Protocol), you should know the basics of EIGRP routing protocol. EIGRP is an enhanced version of IGRP. The core features of the EIGRP routing protocol remain same as provided by the IGRP protocol. However, it provides better performance and scalability than IGRP. EIGRP is one of the most preferred, best, and loved routing protocol. Unfortunately, it is a vendor-specific “Cisco-proprietary” protocol and can only be used on Cisco routers. In this post, we will discuss the basic features of EIGRP protocol, EIGRP tables, and the EIGRP configuration commands with examples.

Features of EIGRP Protocol

Some of the major characteristics and features provided by the EIGRP routing protocol are:

  • It is an Interior Gateway Routing (IGP) protocol, means it can only be used to perform routing within the same autonomous system.
  • It supports up to 255 hops count.
  • It is used for a mid-sized network.
  • It uses composite metric (bandwidth, load, reliability, delay, and MTU) to calculate the best path.
  • It uses Diffusing Update Algorithm (DUAL).
  • Since it has the characteristics of both, the distance vector and link-state protocols, hence, sometimes is referred as a hybrid protocol. However, I have seen many times that Cisco called it as an advanced distance-vector routing protocol.
  • It supports multiple routed protocols, such as IP, Apple Talk, and IPX.
  • The Administrative Distance value of the EIGRP protocol is 90.
  • Unlike IGRP, it is a classless routing protocol, hence, it supports CIDR and VLSM.
  • It also supports route summarization and discontinuous network.
  • It supports up to six equal or unequal paths to provide load balancing for a single destination.
  • The route update time of EIGRP protocol is 90 seconds.
  • It supports trigger update which helps to reduce the size routing table.
  • It uses 224.0.0.10 multicast address to exchange routing information between (neighbors) routers.

In a trigger update, only the partial routing changes are exchanged instead of the full routing tables. It helps to reduce CPU overhead and preserve network bandwidth.

EIGRP Tables

Since the EIGRP protocol has the characteristics of link-state routing protocol, it uses three different types of tables for fast convergence.

  • Neighbor table: Used to store information about the directly connected routers (called neighbors).
  • Topology table: Used to store information about all the possible routes from a source to destination. In addition, it also stores the entire logical network structure.
  • Routing table: Used to store routing information. The best path for a destination called successor is stored in the routing table and all other alternative paths, called feasible successors, for the same destination are stored in the topology table.

Step by Step EIGRP Configuration

Now, you have learned the basics of the EIGRP routing protocol, let us have a look EIGRP configuration. To configure EIGRP, we will use the following topology.

EIGRP Configuration Topology

Configure the IP addresses, as mentioned in the preceding topology on each device. Once you have configured the appropriate IP addresses, you can start to configure EIGRP routing. Before doing so, first, look at the EIGRP configuration command’s syntax.

Router(config)#router eigrp <autonomous number>
Router(config)#network <destination network>

To configure EIGRP routing, you need to perform the following steps:

  • On Router1, execute the following commands.
Router1(config)#router eigrp 500
Router1(config-router)#network 10.0.0.0
Router1(config-router)#network 192.168.1.0
Router1(config-router)#exit
  • On Router2, execute the following commands.
Router2(config)#router eigrp 500
Router2(config-router)#network 20.0.0.0
Router2(config-router)#network 192.168.1.0
Router2(config-router)#network 150.150.0.0
Router2(config-router)#exit
  • On Router3, execute the following commands.
Router3(config)#router eigrp 500
Router3(config-router)#network 150.150.0.0
Router3(config-router)#exit

EIGRP Commands

You can use various EIGRP commands to test, verify, and troubleshoot the EIGRP configuration. The following are some of the commonly used EIGRP commands.

  • To view the routing table, execute the following command.
Router#show ip route
  • To view the neighbor table, execute the following command.
Router#show ip eigrp neighbors

The following figure displays the EIGRP routing and neighbors tables.

eigrp commands

As you can see in the preceding figure, the 20.0.0.0/8 ad 150.150.0.0/16 networks are added through the EIGRP routing protocol.

  • To view information about the EIGRP routing protocol operations, execute the following command.
Router#show ip protocols

The show ip protocols command

  • To view the EIGRP metric information for an interface, execute the following command.
Router#show interface <interface name/number>

The following figure displays the EIGRP metrics for the FastEthernet 0/0 interface.

The show interfaces command

Once you have configured the EIGRP configuration, test your configuration by checking the connectivity between PC0 and Router3. To do so, open the Command Prompt window on PC0, and execute the following command.

PC0>ping 150.150.150.2

You should be able to ping successfully as shown in the following figure.

The ping command

In this post, we have discussed the basic features of EIGRP protocol, EIGRP configuration steps, and some of the important EIGRP configuration commands. Let us know if you have any query. We would love to hear you.

What’s next?

Introduction to OSPF routing protocol.

Configure OSPF routing protocol.

Posted in Cisco, Routing Tagged with: , , ,

Leave a Reply

Your email address will not be published. Required fields are marked *

*