RIP Configuration in Packet Tracer | Step By Step Guide

In the previous post, we have discussed the basics of routing and how to configure static routing. In this post, we will discuss some of the key features of Routing Information Protocol (RIP) and the step by step guide to configure RIP on Cisco routers using Cisco Packet Tracer.

RIP protocol is an open standard, distance-vector, Interior Gateway Routing (IGP) routing protocol. Since it is an IGP protocol, it can only be used to perform routing between networks within the same autonomous system. Typically, it is suitable for a small-sized network.

Features of RIP Routing Protocol

Some of the of key features of RIP protocol are:

  • It supports maximum 15 hops in a path.
  • It uses hops count metric to calculate the best path from a source to a destination network.
  • It sends routing updates (entire routing table) after every 30 seconds and when the network changes.
  • It uses UDP broadcast packets to exchange routing information.
  • The Administrative Distance (AD) value of the RIP protocol is 120.
  • It has two versions: RIPv1 and RIPv2.

RIPv1 vs RIPv2 Differences

There are two versions of RIP protocols: RIP version 1 (RIPv1) and RIP version 2 (RIPv2). The basic features, such as hops count and metric, of both the RIPv1 and RIPv2 protocols remain same. However, RIPv2 is an enhanced version of RIPv1. RIPv2 provides more functionalities than RIPv1. The following table lists the key differences between RIPv1 and RIPv2.

RIP version 1 vs RIP version 2

Routing Loops

If you want to configure RIP protocol on your network, you have to be familiar with the routing loops. Sometimes routing loops create a big issue on an RIP-based network. However, RIP protocol has some mechanisms that can be used to prevent the routing loops and maintain the network stability. These mechanisms are:

  • Split horizon: In the split horizon, route information is not sent back out through the interface from which it was received. Thus, allowing to prevent routing loops.
  • Hop-count limit: Limiting the hop-count prevents routing loops from continuing indefinitely.
  • Poison reverse: In this mechanism, a router marks a route (that is not accessible) as unreachable and set the hop count to 16. The router then passes this route out to the neighbor router, and the neighbor router removes the unreachable route from its routing table.
  • Hold-down timers: When the hold-down timers are set, routers ignore the routing update information for the set period of time.

RIP Timers

Routing protocols use timers to optimize the network performance. The following table lists the various types of timers used by the RIP protocol to optimize the network performance.

Routing Information Protocol Timers

RIP Configuration

To demonstrate how to configure RIP in Cisco Packet Tracer, we will use the following network topology. If you are using a simulator, such as Cisco Packet Tracer or GNS3, create the following topology and configure the IP addresses as mentioned in the topology.Configure RIP Routing

If you are using a simulator, such as Cisco Packet Tracer or GNS3, create the preceding topology and configure the devices as per the values mentioned in the following table.Configure RIP Routing

First of all, configure the IP addresses on each device. We assume that you know how to configure IP addresses. If you stuck in configuring IP addresses, click here to know how to configure IP address or you can refer the following example.

For example, to configure TCP/IP addresses on Router1, execute the following commands:

Router1(config)#interface fa0/1
Router1(config-if)#ip add 10.0.0.1 255.0.0.0
Router(config-if)#no shut
Router1(config-if)#exit

Router1(config)#interface S1/0
Router1(config-if)#ip add 192.168.1.1 255.255.255.0
Router1(config-if)#clock rate 64000
Router(config-if)#no shut

The following figure shows the IP configuration of Router1.
configure ip address on Cisco Router

Steps to Configure RIP Routing

Once you have configured the appropriate IP addresses on each device, perform the following steps to configure RIP routing. The default version of RIP is RIPv1. In the later section, we will also configure RIPv2 routing.

  1. On Router1, execute the following commands to configure RIP routing.
Router1(config)#router rip
Router1(config-router)#network 10.0.0.0
Router1(config-router)#network 192.168.1.0
Router1(config-router)#exit
  1. On Router2, execute the following commands to configure RIP routing.
Router2(config)#router rip
Router2(config-router)#network 20.0.0.0
Router2(config-router)#network 192.168.1.0
Router2(config-router)#network 150.150.150.0
Router2(config-router)#exit
Router2(config)#
  1. On Router3, execute the following commands to configure RIP routing.
    Router3(config)#router rip
    Router3(config-router)#network 150.150.150.0
    Router3(config-if)#exit
  2. Once you have configured RIP routing protocol on each router, wait for a few seconds (let complete the convergence process), and then execute the show ip route command on any router to show the routing information.
    Router(config)#do show ip route
  3. In the following figure, you can see the routes learned by the RIP protocol on Router3.

Verify RIP routing

Verifying RIP Configuration

To verify and test the RIP configuration, perform the following steps:

  1. To verify which routing protocol is configured, use the show ip protocols command.
Router#show ip protocols
  1. To view the RIP messages being sent and received, use the debug ip rip command.
Router#debug ip rip
  1. To stop the debugging process, use the undebug all command.
Router#undebug all

Configure RIP Version 2 (RIPv2)

The configuration process of the RIPv2 protocol is similar to configuring RIPv1 protocol. To configure the RIPv2 routing protocol, you just need to type version 2 command before executing the network command. To configure the RIPv2 protocol, perform the following tasks on each router.

  1. On Router1, execute the following commands:
    Router1(config)#router rip 
    Router1(config-router)#version 2
  2. On Router2, execute the following commands:
    Router2(config)#router rip 
    Router2(config-router)#version 2
  3. On Router3, execute the following commands:
    Router3(config)#router rip 
    Router3(config-router)#version 2
  4. Once you have executed the preceding commands, execute the following command on each router, and verify the configuration as shown in the following figure.
    Router#show ip protocols

show ip protocols command

Question: Which version of Routing Information Protocol should you use for a discontinuous network?

Removing RIP Routing Configuration

If you have added a wrong network or route, you can remove that network from the routing table. In this section, we will learn how to remove the routes learned by the RIP protocol. To do this, perform the following tasks.

  • On Router1, execute the following commands.
Router1(config)#router rip
Router1(config-router)#no network 10.0.0.0
Router1(config-router)#no network 192.168.1.0
Router1(config-router)#exit
  • On Router2, execute the following commands.
Router2(config)#router rip
Router2(config-router)#no network 20.0.0.0
Router2(config-router)#no network 192.168.1.0
Router2(config-router)#no network 150.150.150.0
Router2(config-router)#exit
  • On Router3, execute the following commands.
Router3(config)#router rip
Router3(config-router)#no network 150.150.150.0
Router3(config-router)#exit

Now, execute the show ip route command and verify that the routes learned by the RIP routing protocol are deleted. If the routes are still available in the routing table, execute the clear ip route * command.

In this post, we have discussed the basic features of RIP and the differences between RIP version 1 and RIP version 2. In addition, we have also explained steps to configure RIP in Cisco Packet Tracer. Please share your valuable feedback to improve the topic.

What’s next?

How to configure EIGRP routing.

Posted in Cisco, Routing Tagged with: , ,
3 comments on “RIP Configuration in Packet Tracer | Step By Step Guide
  1. Vikas says:

    Great explanation… keep it up
    .

  2. Imannuel says:

    This is the best thing i’ve found thus far on the internet. I’ve gone from know absolutely nothing to setting up a network topolgy with RIP V1 and V2 protocol. You’re the best!!! I want more XD

Leave a Reply

Your email address will not be published. Required fields are marked *

*