How To Configure Frame Relay in Cisco Packet Tracer

Configuring frame relay encapsulation is a little bit tricky and complicated. However, it is not as difficult as people think. In this post, we will explain a step by step guide to configure frame relay in Cisco Packet Tracer. However, we will not cover the theory part of the frame relay technology in this post. We assume ou are already familiar with basics of Frame Relay technology. You may use either Cisco Packet Tracer or GNS3 simulator depending on your choice.

Also read: How to configure Frame Relay in GNS3.

Creating Frame Relay Topology in Cisco Packet Tracer

We will create the following frame relay topology using Cisco Packet Tracer.Create Frame relay Topology in Cisco Packet Tracer

First of all, add all the routers and a frame relay switch in Cisco Packet Tracer. Next, interconnect all the devices using the appropriate interfaces as mentioned in the preceding topology. Once you have created the topology, the next step is to specify the frame relay interfaces, DLCI, and other parameters. To do so, you need to perform the following steps:

  1. In the right pane, select the values in the following order from the drop-down lists, and then click Add. It will create a frame-relay connection between Router1 and Router3.
  2. Next, select Frame Relay under CONNECTIONS.
  3. Next, select Serial2 interface, type 301 in the DLCI field, type R3-R1 in the Name field, and then click Add.
  4. Next, select Serial1 interface, type 201 in the DLCI field, type R2-R1 in the Name field, and then click Add.
  5. Again, type 103 in the DLCI field, type R1-R3 in the Name field, and then click Add. After performing these steps, the Cloud0 properties dialog box should look like the following figure.Creating Frame Relay Connection in Cisco Packet Tracer
  6. Type 102 in the DLCI field, type R1-R2 in the Name field, and then click Add.
  7. Double-click on Cloud0. On the Cloud0 properties dialog box, select Serial0 under INTERFACE.
    1. Seria0
    2. R1-R2
    3. Serial
    4. R2-R1
  8. Again, select the values in the following order from the drop-down lists, and then click Add. It will create a frame-relay connection between Router1 and Router3.
    1. Serial0
    2. R1-R3
    3. Serial2
    4. R3-R1
  9. The following figure to shows how to make the frame-relay connections.Adding Frame Relay Connections in Packet Tracer
  10. Once you have created the frame-relay connections, close the Cloud0 properties dialog box.

Steps to Configure Frame Relay in Cisco Packet Tracer

After creating the frame relay topology, the next step is to configure frame relay. You can configure either point-to-point or point-multipoint frame relay depending on your requirement. In this demonstration, we will configure point-to-point frame relay. To do so, you need to execute the following commands:

  1. Move on to Router1 and execute the following commands to enable frame relay encapsulation on the se2/0 interface.
    Router1(config)#interface se2/0 
    Router1(config-if)#encapsulation frame-relay 
    Router1(config-if)#no shut Router1(config-if)#exit
  2. Next, execute the following commands to create the point-to-point frame relay sub-interfaces (one for Router2 and one for Router3), assign the IP addresses, and specify the DLCI numbers.
    Router1(config)#interface se2/0.102 point-to-point 
    Router1(config-subif)#ip add 10.0.0.1 255.0.0.0 
    Router1(config-subif)#frame-relay interface-dlci 102 
    Router1(config-subif)#exit 
    Router1(config)#interface se2/0.103 point-to-point 
    Router1(config-subif)#ip add 20.0.0.1 255.0.0.0 
    Router1(config-subif)#frame-relay interface-dlci 103
    Router1(config-subif)#exit
  3. Next, execute the following commands to specify a routing method, in this case, Routing Information Protocol (RIP). However, you may use any of the routing methods.
    Router1(config)#router rip
    Router1(config-router)#network 10.0.0.0
    Router1(config-router)#network 20.0.0.0
    Router1(config-router)#exit
  4. The following figure shows the point-to-point frame relay configuration of Router1.Configure Frame Relay in Cisco Packet Tracer
  5. After configuring frame relay on Router1, move on to Router2. Execute the following commands to configure the point-to-point frame relay and RIP routing.
    Router2(config)#interface se2/0
    Router2(config-if)#ip add 10.0.0.2 255.0.0.0
    Router2(config-if)#encapsulation frame-relay
    Router2(config-if)#frame-relay interface-dlci 201
    Router2(config-if)#no shut
    Router2(config-if)#exit
    
    Router2(config)#router rip
    Router2(config-router)#network 10.0.0.0
    Router2(config-router)#exit
  6. After configuring frame relay on Router1 and Router2, move on to Router3. Execute the following commands to configure point-to-point frame relay and RIP routing.
    Router3(config)#interface se2/0
    Router3(config-if)#ip add 20.0.0.2 255.0.0.0
    Router3(config-if)#encapsulation frame-relay
    Router3(config-if)#frame-relay interface-dlci 301
    Router3(config-if)#no shut
    Router3(config-if)#exit
    Router3(config)#router rip
    Router3(config-router)#network 20.0.0.0
    Router3(config-router)#exit

Verifying Frame Relay Configuration

  1. Now, you have configured the point-to-point frame relay encapsulation on all the routers. Next, verify your frame relay configuration. To do so, execute the following commands on Router3 and examine the output of each command.
    Router3#show frame-relay pvc
    Router3#show frame-relay map
  2. The following figure shows the frame relay verification commands.
    Verify Frame-relay configuration

In the preceding figure, you can see that frame relay encapsulation has been configured on the Serial2/0 interface of Router3. Use the same commands to verify your frame relay configuration on Router2 and Router3.

In this post, we have learned how to configure frame relay in Cisco Packet Tracer. Hope, it helped you. If you stuck anywhere, please drop your queries in the comment box, we will try to address them. You can also share the post if you think it may help to others too.

Posted in CCNA, Cisco Tagged with: , ,

Leave a Reply

Your email address will not be published. Required fields are marked *

*