How to Configure Etherchannel on Cisco Switch

EtherChannel is a technique that allows you to combine multiple Ethernet ports into a single logical port. Thus, helping you to combine the bandwidth of multiple ports. In addition, it also provides redundancy in case of a single port failure. For example, consider a scenario in which you combine Fa0/1 and Fa0/2 interfaces, each supporting up to 100 Mbps of bandwidth, into a logical port (channel group) named LogicalPort1. The aggregate bandwidth of the LogicalPort1 port would be 200 Mbps. This is what called Link Aggregation. Further, if one of your interfaces (such as Fa0/1) from the channel group goes down, the other interface (such as Fa0/2) would still be able to provide connectivity. This is what called Redundancy. The EtherChannel technique is also known as NIC Teaming (in Microsoft), Link Aggregation (in Cisco), or Ethernet Bridging (in Linux). In this post, we will explain how to configure EtherChannel.

Recommended post: Configure port security on Cisco switch.

PAgP vs LACP

You can use any of the following methods to implement the EtherChannel technique:

  1. PAgP stands for Port Aggregation Protocol. It is the Cisco-proprietary negotiation protocol.
  2. LACP stands for Link Aggregation Control Protocol. It is an open standard negotiation protocol.
  3. Static; it does not require any protocol. The negotiation between Ethernet ports is done manually.

In this post, we will discuss how to configure EtherChannel between two Cisco switches.

In order to configure EtherChannel, you should use at least two Ethernet ports. To demonstrate how to configure EtherChannel, we will use the Fa0/1 and Fa0/2 interfaces of both the switches. The following figure shows the topology that we will use to configure EtherChannel.Configure EtherChannel On Cisco Switch

Before configuring EtherChannel, let’s have a look at the commands used to configure it. The following figure shows the commands used to configure EtherChannel on Cisco switches.Commands to Configure EtherChannel

Steps to Configure EtherChannel

In order to configure EtherChannel between Cisco switches, you need to perform the following steps.

  1. Execute the following command to define the interfaces that you want to include in the EtherChannel mode.
    Switch1(config)#interface range fa0/1-2
  1. Next, execute the following commands to define a channel group name and the EtherChannel mode. In this example, we will use “on” (static) mode.
Switch1(config-if-range)#channel-group 1 mode on
Switch1(config-if-range)#exit
  1. Next, execute the following commands to define the mode of the interface (in this case, trunk mode) for your channel group.
Switch1(config)#interface port-channel 1
Switch1(config-if)#switchport mode trunk
  1. The following figure displays the EtherChannel configuration of Switch1.How to configure EtherChannel on Cisco Switch
  1. Once you have configured Switch1, move on to Switch2 and execute the following commands:
Switch2(config)#interface range fa0/1-2
Switch2(config-if-range)#channel-group 1 mode on
Switch2(config-if-range)#exit
Switch2(config)#interface port-channel 1
Switch2(config-if)#switchport mode trunk
  1. To verify your configuration, execute the following command and examine the output as displayed in the following figure.
Switch2#show etherchannel summary

Commands to Verify EtherChannel

  1. In the preceding figure, you can see that EtherChannel has been configured between the Fa0/1 and Fa0/2 interfaces of Switch1 and Switch2.

In this post, we have explained the basics of the EtherChannel technique and how to configure EtherChannel on Cisco switches. Hope, it helped you. Please share the post if you think it can help others too.

Posted in Cisco, Switching Tagged with: , ,

Leave a Reply

Your email address will not be published. Required fields are marked *

*